Data visibility issues in Merchant Portal

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 16:19 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2026 - 11:12 CEST

Update

We are continuing to work on a fix for this issue.
Posted Aug 28, 2026 - 10:52 CEST

Identified

We are currently experiencing issues displaying data in Merchant Portal since approximately 04:20. This affects the visibility of transactions, batches, service charges, and other portal data. Payment processing is not affected. (edited)
Posted Aug 28, 2026 - 10:36 CEST
This incident affected: Portals (Merchant Portal).