Service Disruption - Terminals using WiFi connectivity

Incident Report for Swedbank Pay

Update

Our investigation indicates that the issue is related to a DNS update on a Telia network during the night, affecting connectivity between terminals and our transaction host.

What customers can do:

If you are experiencing transaction issues, please contact your network provider and ask them to review and change the DNS settings used by your connection.

We are continuing our investigation and are working to establish whether a broader resolution can be implemented.
Posted Jul 23, 2026 - 11:54 CEST

Identified

We are currently experiencing a service disruption with PAX-terminals using WiFi.

We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jul 23, 2026 - 11:27 CEST
This incident affects: Accept Payments (Instore Card Payments).