Issue with email dispatch for payment confirmations

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 16:04 CEST

Investigating

There was an issue with the email dispatch for the payment confirmations on orders.
This was resolved 15:30
Posted Sep 03, 2025 - 13:30 CEST