At the moment, Swish are experiencing a disturbance impacting transactions to and from Riksbanken.

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 15:31 CET

Update

We are continuing to investigate this issue.
Posted Mar 05, 2025 - 14:51 CET

Investigating

We are currently investigating this issue.
Posted Mar 05, 2025 - 14:49 CET
This incident affected: Payment Solutions (Swish).