Westpay - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 07:48 CET

Monitoring

Payouts are expected to be made tomorrow, March 28th.
Posted Mar 27, 2025 - 09:13 CET

Identified

Westpay are currently having issues with clearing files which will cause delays with payouts to some customers.
We apologize for any inconvenience this may cause.
Posted Mar 27, 2025 - 08:41 CET
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).