Incorrect reference number on account statement
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 13:06 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2023 - 16:58 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 16, 2023 - 16:56 CET
Identified
We have discovered that the reference number shown on your account statement is incorrect, the last two digits differs from the correct one. This affects the customers that was debited by us yesterday (15/11). We have resolved the error so that it does not occur in next month's draw, but unfortunately we cannot correct the reference number that is already in your bank statement.
No actions are needed to be taken on your part, we just want to draw your attention to this detail.

Sorry for any inconvenience this may cause.
Posted Nov 16, 2023 - 12:49 CET
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).