At the moment, Swish are experiencing a disturbance impacting transactions to and from Nordea.

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Mar 02, 2025 - 16:21 CET

Update

We are continuing to investigate this issue.
Posted Mar 02, 2025 - 16:20 CET

Update

We are continuing to investigate this issue.
Posted Mar 02, 2025 - 15:41 CET

Investigating

Swish are currently investigating this issue.
Posted Mar 02, 2025 - 15:41 CET
This incident affected: Payment Solutions (Swish).