Swedbank Pay - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Resolved

The issue has been resolved and payouts are expected to be made during the day.
Posted Apr 24, 2025 - 07:22 CEST

Update

We are continuing to investigate this issue. We apologize for any inconvenience this may cause and appreciate your continued patience.
Posted Apr 23, 2025 - 12:14 CEST

Investigating

We are currently experiencing issues which may result in delays in payouts for some Swedish customers with Swedbank Pay as PSP their. We apologize for any inconvenience this may cause and are working to resolve this matter promptly.
Posted Apr 22, 2025 - 14:18 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).