Disturbances with clearing and settlement
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 08:24 CET
Monitoring
Payouts are expected to be made on Monday, January 13th.
Posted Jan 10, 2025 - 15:04 CET
Investigating
We are currently experiencing disturbances with our clearing and settlement services which will cause delays with payouts to some customers. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Jan 10, 2025 - 08:20 CET
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).