Verifone - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 08:15 CEST

Monitoring

Payouts are expected to be made tomorrow, April 1st.
Posted Mar 31, 2025 - 13:18 CEST

Investigating

We are currently experiencing issues with clearing files from Verifone, which may result in delays in payouts for some customers. We apologize for any inconvenience this may cause and are working to resolve this matter promptly.
Posted Mar 31, 2025 - 09:28 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).