Swish Service Disruption
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Mar 08, 2023 - 18:33 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 08, 2023 - 18:33 CET
Identified
Swish has reported some service disruption. This affects some payments. We are monitoring the situasion. Thank you for your patience.
Posted Mar 08, 2023 - 18:17 CET
This incident affected: Payment Solutions (Swish).