Swish 3rd Party Service Disruption

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 15, 2025 - 21:16 CEST

Monitoring

Swish has implemented a fix and is monitoring.
Posted May 15, 2025 - 21:15 CEST

Investigating

Swish has notified that they are experiencing a disturbance and that they are investigating.
Posted May 15, 2025 - 20:34 CEST

Identified

We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted May 15, 2025 - 20:29 CEST
This incident affected: Payment Solutions (Swish).