Verifone - Delayed payouts - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Identified

We are continuing to work on a fix for this issue.
Posted Dec 03, 2025 - 15:35 CET

Update

We are continuing to investigate this issue.
Posted Dec 03, 2025 - 09:06 CET

Investigating

We are currently experiencing issues with clearing files from Verifone, which may result in delays in payouts for some customers. We apologize for any inconvenience this may cause and are working to resolve this matter promptly.
Posted Dec 03, 2025 - 09:03 CET
This incident affects: Acquiring of Card Transactions (Clearing & Settlement).