Delays in Merchant Portal

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 17:21 CET

Investigating

We are currently experiencing delays in the Merchant Portal. This can cause some data (transactions and documents) to be unavailable.

The issue is being worked on to ensure that the data is available in the Merchant Portal as soon as possible.

Thank you for your patience.
Posted Mar 03, 2025 - 09:01 CET
This incident affected: Web Portal's (Merchant Portal).