Swedbank Pay Card Authorization

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 10:44 CEST

Investigating

We are currently experiencing technical issues affecting card transaction authorizations. Some customers may notice declined transactions or time outs. Our team is working to restore full functionality, we apologize for any inconvenience.
Posted Jun 02, 2026 - 10:40 CEST
This incident affected: Accept Payments (Instore Card Payments, Online Card Payments).