Online Card Payments – Degraded performance due to external dependency

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 11:00 CEST

Identified

We are currently experiencing issues affecting online card payments due to an external dependency.

Customers may experience increased response times or declined transactions when attempting to complete purchases.

We are in contact with the affected party and are working to resolve the issue.
Posted Jul 15, 2026 - 09:24 CEST
This incident affected: Accept Payments (Online Card Payments).