Verifone - Delayed payouts

Incident Report for Swedbank Pay

Monitoring

The payouts are expected to be made on Monday, the 7th of July.
Posted Jul 04, 2025 - 15:53 CEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 04, 2025 - 08:39 CEST

Identified

We are currently experiencing issues with clearing files from Verifone, which may result in delays in payouts for some customers. We apologize for any inconvenience this may cause and are working to resolve this matter promptly.
Posted Jul 03, 2025 - 08:19 CEST
This incident affects: Acquiring of Card Transactions (Clearing & Settlement).