Trustly - Delayed payouts

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 09:11 CET

Monitoring

The payouts are expected to be made on Monday, the 10th of November.
Posted Nov 07, 2025 - 14:16 CET

Update

We are still working to be able to do the payouts.
Posted Nov 06, 2025 - 10:41 CET

Identified

We are currently experiencing issues with settlement regarding Trustly , which result in delays in payouts for some customers. We apologize for any inconvenience this may cause and are working to resolve this matter promptly.
Posted Nov 05, 2025 - 13:08 CET
This incident affected: Payment Solutions (Trustly).