Delays in Merchant Portal

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 16:45 CEST

Update

We are continuing to investigate this issue.
Posted Apr 22, 2025 - 12:19 CEST

Investigating

We are currently experiencing delays in the Merchant Portal, which may cause some data, such as transactions and documents, to be unavailable. We are working to resolve the issue and ensure the data is available as soon as possible.

Thank you for your patience.
Posted Apr 17, 2025 - 09:27 CEST
This incident affected: Web Portal's (Merchant Portal).