Disturbance at Swish impacting Swish payments

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 06, 2025 - 13:46 CEST

Investigating

At the moment, Swish are experiencing a disturbance impacting Swish payments.
Posted May 06, 2025 - 12:43 CEST
This incident affected: Payment Solutions (Swish).