Swish Service Disruption
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 15:20 CEST
Identified
Swish are currently experiencing a service disruption. They are working to restore the service as soon as possible. Thank you for your patience.
Posted Jun 05, 2023 - 14:30 CEST
This incident affected: Payment Solutions (Swish).