3D Secure authentication degradation
Incident Report for Swedbank Pay
Resolved
Mastercard directory server is now responding as usual.
Posted Jan 17, 2023 - 15:59 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 17, 2023 - 15:58 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 17, 2023 - 15:51 CET
Identified
We are currently experiencing a service degradation. We are working to restore the service as soon as possible. Thank you for your patience
Posted Jan 17, 2023 - 15:15 CET
This incident affected: Payment Solutions (m/ecom Card Payments).