Verifone - Delayed payouts

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 08:07 CEST

Monitoring

The payouts are expected to be made on Wednesday, the 11th of June.

This was due to issues with clearing files, which may result in delays in payouts for some customers. We apologize for any inconvenience this may cause.
Posted Jun 10, 2025 - 08:02 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).