Delays in Merchant Portal
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Aug 30, 2024 - 07:59 CEST
Identified
We are currently experiencing delays in the Merchant Portal. This can cause some data (transactions and documents) to be unavailable.

The issue is being worked on to ensure that the data is available in the Merchant Portal as soon as possible.

Thank you for your patience.
Posted Aug 26, 2024 - 13:45 CEST
This incident affected: Web Portal's (Merchant Portal).