Swedbank Pay - Delayed payouts - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 27, 2026 - 08:05 CEST

Identified

We are continuing to work on this issue.

Thank you for your patience.
Posted May 26, 2026 - 16:46 CEST

Investigating

We are currently experiencing issues with clearing files, which may cause delays in payouts for some merchants using Swedbank Pay as their PSP. We are working to resolve the issue as quickly as possible and apologize for any inconvenience.
Posted May 26, 2026 - 08:32 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).