Swish Service Disruption
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 16:45 CEST
Identified
We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 16, 2022 - 13:38 CEST
This incident affected: Payment Solutions (Swish).