Swish Service Outage
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 14:21 CEST
Investigating
Swish are experiencing a major outage and is investigating.
Posted Sep 06, 2024 - 13:42 CEST
This incident affected: Payment Solutions (Swish).