Swedbank Pay - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 08:37 CEST

Monitoring

We are currently experiencing some delays in payouts for Swedish customers using Swedbank Pay as their PSP. The issue has been identified and resolved, and we expect payouts to be made tomorrow. We apologize for any inconvenience and appreciate your understanding.
Posted Apr 24, 2025 - 16:23 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).