Delayed settlements for merchants using Verifone Greenbox
Incident Report for Swedbank Pay
Resolved
Incident solved and files with transactions from 26/5 and 28/5 have been re-sent from Verifone. The files will be processed this evening.
Posted May 29, 2023 - 15:56 CEST
Investigating
We are currently investigating this issue together with Verifone.
Posted May 29, 2023 - 09:40 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).