Swedbank Pay - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 06, 2025 - 09:21 CEST

Monitoring

The delayed payouts are expected to be made on Friday the 2nd of May.
Posted Apr 30, 2025 - 13:41 CEST

Investigating

We are currently experiencing issues which may result in delays in payouts for some customers with Swedbank Pay as their PSP. We apologize for any inconvenience this may cause and are working to resolve this matter promptly.
Posted Apr 30, 2025 - 08:36 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).