Merchant Portal – Degraded Functionality

Incident Report for Swedbank Pay

Monitoring

The majority of the reported issues affecting the Merchant Portal have now been resolved, and service functionality has improved significantly.

We will continue to closely monitor the portal to ensure stability and investigate any remaining isolated issues.

We will provide further updates should additional information become available.
Posted Jul 03, 2026 - 18:17 CEST

Update

We are continuing to investigate the issues and work to restore normal functionality as soon as possible.
Posted Jul 03, 2026 - 11:11 CEST

Update

We are continuing to investigate and work to restore normal functionality as soon as possible.
Posted Jul 02, 2026 - 17:06 CEST

Update

We continue to investigate issues affecting the Merchant Portal.

Customers may experience intermittent issues related to information displayed or exported from the portal.

We are actively investigating and working to restore normal functionality as soon as possible.
Posted Jul 01, 2026 - 15:41 CEST

Identified

We are currently experiencing an issue in the Merchant Portal where the status of some transactions may be incorrectly displayed as pending, and some transactions may not be visible.

This is a display issue only and does not affect transaction processing.

We are investigating and working to resolve the issue as soon as possible.

Thank you for your patience.
Posted Jul 01, 2026 - 08:48 CEST
This incident affects: Portals (Merchant Portal).