Delayed payouts - External disturbances with clearing and settlement

Incident Report for Swedbank Pay

Monitoring

The issue affecting payout delays, related to an external provider, has now been resolved.

Payouts are being processed, and funds are expected to reach accounts by tomorrow morning.
Posted Jun 08, 2026 - 18:57 CEST

Identified

The issue affecting delayed settlements is still ongoing.

Payouts will be processed once the issue, related to an external provider, is resolved.
Posted Jun 08, 2026 - 16:40 CEST

Investigating

Some merchants may experience delays in payouts for sales from the weekend (5–7 June).

The delays are due to an issue with an external provider in the payment processing chain. Payouts will be processed once the issue is resolved.

No action is required from your side at this time.
Posted Jun 08, 2026 - 13:15 CEST
This incident affects: Merchant Payouts (Merchant Payouts).