Swedbank Pay - Disturbances with clearing and settlement
Incident Report for Swedbank Pay
Resolved
The incident has been resolved and the payouts are expected to made on the 11th of April.
Posted Apr 10, 2024 - 17:09 CEST
Identified
We are currently having issues with clearing files which will cause delays with payouts to customers with Swedbank Pay as technical provider. The issue is being investigated, thank you for your patience.
Posted Apr 10, 2024 - 10:48 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).