Swish Service Disruption

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Apr 04, 2026 - 18:43 CEST

Update

Swish is reporting a service disruption via their statuspage. They are investigating
Posted Apr 04, 2026 - 18:30 CEST

Investigating

We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Apr 04, 2026 - 18:19 CEST
This incident affected: Payment Solutions (Swish).