Degraded performance for transactions

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 01, 2025 - 04:34 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2025 - 03:29 CEST

Investigating

We are currently investigating this issue.
Posted May 01, 2025 - 02:52 CEST
This incident affected: Payment Solutions (Instore Card Payments, m/ecom Card Payments).