CreditCard service disruption

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 20:35 CET

Update

We are continuing to work on a fix for this issue.
Posted Mar 24, 2025 - 14:16 CET

Identified

We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Mar 24, 2025 - 14:08 CET
This incident affected: Payment Solutions (m/ecom Card Payments).