Delayed payouts - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 15:40 CEST

Investigating

We are currently experiencing delays in payouts, which may affect some customers using Swedbank Pay as their PSP. We are investigating the issue and working to resolve it.
Posted Jun 22, 2026 - 15:25 CEST
This incident affected: Merchant Payouts (Merchant Payouts).