Service Disruption - PayByLink

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 15:40 CET

Identified

We are currently experiencing a disruption affecting the PayByLink service via the Merchant Portal. Our team is actively working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Mar 06, 2025 - 09:41 CET
This incident affected: VAS (PayByLink).