Delays in Merchant Portal
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 09:00 CEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2024 - 08:59 CEST
Identified
We are currently having issues in Merchant Portal which will cause some delays in showing latest transactions. We are working on resolving this issue as soon as possible.
Thank you for your patience.
Posted Apr 12, 2024 - 11:32 CEST
This incident affected: Web Portal's (Merchant Portal).