Acquiring Batches in Merchant Portal

Incident Report for Swedbank Pay

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2026 - 12:29 CEST

Investigating

We are currently having problems with listing batches in the Merchant Portal, for Acquirer Payments
Posted Apr 24, 2026 - 11:37 CEST
This incident affects: Web Portal's (Merchant Portal).