Service Disruption - Card Authorization
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Mar 08, 2023 - 11:36 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2023 - 09:12 CET
Investigating
We are currently experiencing a service disruption in card payments affecting some merchants.
Posted Mar 08, 2023 - 07:30 CET
This incident affected: Acquiring of Card Transactions (Card Authorization).