Disturbances at Nets

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 22, 2026 - 08:26 CEST

Monitoring

A fix has been implemented by Nets and the issue has stabilized.

We are monitoring the situation to ensure that normal operations are fully restored.
Posted May 21, 2026 - 15:56 CEST

Update

Nets are continuing to work on a fix for this issue.
Posted May 21, 2026 - 11:49 CEST

Identified

Nets is currently experiencing an issue causing transactions to be declined. The issue is under investigation by them.

Thank you for your patience.
Posted May 21, 2026 - 09:30 CEST
This incident affected: Payment Solutions (Instore Card Payments, Online Card Payments).