At the moment, Länsförsäkringar is experiencing a disturbance that may impact Swish transactions

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 08:48 CET

Investigating

We are currently investigating this issue.
Posted Nov 27, 2025 - 20:23 CET
This incident affected: Payment Solutions (Swish).