Delayed Payouts/Försenade utbetalningar
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 10:45 CEST
Identified
Our third party are having issues with clearing files which will cause delays in payouts to some customers.
Sorry for any inconvenience this may cause.
Posted Apr 11, 2024 - 13:02 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).