Vipps Service Disruption
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Nov 17, 2023 - 22:37 CET
Identified
We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 17, 2023 - 20:17 CET
This incident affected: Payment Solutions (Vipps).