Ongoing Investigation: Increased Declines in eCom

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 18:20 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2026 - 17:58 CET

Investigating

We are currently experiencing an increased number of declines in our eCom environment. Our teams are actively investigating the issue and working to identify the root cause.

This does not affect our own acquiring services.

Updates will be provided as soon as more information becomes available.
Posted Feb 13, 2026 - 15:43 CET
This incident affected: Payment Solutions (m/ecom Card Payments).