At the moment, Nordea is experiencing a disturbance that may impact Swish transactions to and from Nordea.

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 19:53 CET

Investigating

We are currently investigating this issue.
Posted Dec 01, 2025 - 16:47 CET
This incident affected: Payment Solutions (Swish).