Westpay - Disturbances at 3rd party

Incident Report for Swedbank Pay

Resolved

The incident has been resolved. We are continuing to monitor the situation to ensure everything remains stable.
Posted May 14, 2025 - 20:32 CEST

Investigating

Westpay are currently experiencing a service disruption and are working to restore the service as quickly as possible. Thank you for your patience.
Posted May 14, 2025 - 18:40 CEST
This incident affected: Acquiring of Card Transactions (Card Authorization).