Service Disruption
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Aug 27, 2024 - 14:50 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2024 - 14:45 CEST
Update
We are continuing to investigate this issue.
Posted Aug 27, 2024 - 14:33 CEST
Investigating
We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Aug 27, 2024 - 14:18 CEST
This incident affected: Payment Solutions (Instore Card Payments, m/ecom Card Payments, Vipps, MobilePay).