VAS - Partial outage for RetailCard
Incident Report for swedbankpay
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 08:37 CET
Update
We are continuing to investigate this issue.
Posted Nov 18, 2022 - 08:36 CET
Investigating
We are currently investigating this issue.
Posted Nov 18, 2022 - 08:06 CET
This incident affected: VAS (RetailCard).